Problems running ebrary on Internet Explorer

Internet Explorer (IE) is a browser that typically works well with ebrary.  However, plug-ins and extensions added to IE can cause problems.

Troubleshooting tips:

1. Try using a different browser

  • Firefox works particularly well with ebrary
  • If you don’t have Firefox already you can download it free at www.mozilla.com
  • It’s fine to run two different browsers at the same time – you could use Firefox for ebrary and IE for other things

2. If you want to continue using IE for ebrary, try disabling IE extensions

  • This solution has a pretty high success rate
  • Briefly, here’s how to disable IE extensions:

Go to… Start > Run > type ‘Control Inetcpl.cpl’ > Click the Advanced tab
Under Browsing, uncheck ‘Enable third-party browser extensions  (requires restart)’
Restart IE

3. Alternatively you can try doing a complete reset of IE

4) “Compatibility Mode” could be the problem

Problems using Internet Explorer with “Compatibility View” enabled

Internet Explorer has a Compatibility View, a feature that affects how some websites are displayed. If Compatibility View is enabled for ebrary.com, it may cause some features to display incorrectly. So, we suggest that you remove ebrary.com from your list of sites that have Compatibility View enabled to ensure that ebrary displays correctly. To do this, follow the steps below:

For IE 8:

  1. Open the Tools menu at the top of your browser1 and select Compatibility View Settings.
  2. Select ‘ebrary.com’ under ‘Websites you’ve added to Compatibility View’.
  3. Click Remove.When you close the Settings window, the page you’re on will refresh and display in normal IE8 mode.

For IE 9:

  1. Right-click on the gear icon  in the upper right hand corner.
  2. Select Command bar.
  3. Open the Tools menu near the top of your browser and select Compatibility View Settings.
  4. Select ‘ebrary.com’ under ‘Websites you’ve added to Compatibility View’.
  5. Click Remove.

To clear your browser’s cache

For info about your browser, paste this URL into your browser:

http://www.thismachine.info

To clear your browser’s cache (which is always a good idea if you’re experiencing unexpected behavior):

– For Internet Explorer:

1. Under the “Tools” menu

2. Select “Internet Options”

3. Under the “Browsing history” heading

4. Click the “Delete…” button

5. In the menu that pops up, select the check-boxes for at least first six items

6. Click the “Delete” button

7. Then click the “OK” button

8. Close all your browser windows and reopen

Or see: http://support.microsoft.com/kb/260897

– For Mozilla Firefox:

1. Under the “Tools” menu

2. Select “Clear Recent History…”

3. In the menu that pops up, select the check-boxes of all six items

4. Click the “Clear Now” button

5. Close all your browser windows and reopen

Or see: http://support.mozilla.org/en-US/kb/clear-cache-delete-temporary-files-fix-issues

– For Google Chrome:

1. Under the wrench-looking menu

2. Select “Tools” then “Clear browsing data…”

3. In the menu that pops up, select the check-boxes of all six items

4. In the “Clear data from this period” leave it as “Everything”

5. Click the “Clear browsing data” button

6. Close all your browser windows and reopen

Or see: http://support.google.com/chrome/bin/answer.py?hl=en&answer=95582

To check your cookie settings

Exact steps depend on which browser version you’re using, but basically:

Windows computers:

  • Internet Explorer: Tools > Internet Options > Privacy tab.  Level of security Medium (default) or below; Medium-High and High will block cookies. Click on the “Advanced button” and make sure First-Party cookies are set to “Accept”.
  • Firefox: Tools > Options:Privacy Section >Cookies Tab. Check box “Allow sites to set cookies”.

Macintosh computers:

  • Safari: Safari > Preferences > Security. Make sure the check is not on “Disable Cookies”, either one of the other settings should be fine.
  • Firefox: Firefox > Preferences > Privacy Tab. Check box next to “Accept cookies from sites”.

Gathering “Charles” diagnostics

Occasionally, a specific problem may require the collection of special diagnostics that ebrary can use to analyze the problem. The following instructions describe how to record and send this info to ebrary.

  1. First you’ll need to get the Charles Diagnostics software off the web if you don’t already have it (it is a free download):
    1. Go to the following URL:
      http://www.charlesproxy.com/download.php
    2. Download the appropriate version for your system
    3. Install it on a computer that has been experiencing the problem
  2. Start the Charles script software (i.e., begin recording) by clicking the icon with the red round button on it
  3. Open a new browser window or tab
  4. Go directly to your ebrary site
  5. Reproduce the problem you are having
  6. End recording by clicking the icon with the red round button on it again
  7. Save the session (“File” menu, “Save”)
  8. Then please email that file as an enclosure to support@ebrary.com

The file shows the detail of each URL to your browser, all network traffic, and possible error messages recorded during the session.